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1 3 次元 CG を理解するために 

3 次元 CG の基礎知識として、3 次元空間や座標系について理解し、実際、

マウス操作によってカメラ(視点)を変更する実習を行います。さらにモデリン

グとして立体図形の制作を行い、質感設定(マッピング)である色付けや、完成

画像を出力するためのレンダリングを行います。 
アニメーション制作では、物体の動きを制御し、どのように動かすかを学習

することができます。様々な状況に応じて、試してみることで発見・理解・課

題解決へとつながります。 
 
 

2 代表的な 3DCG ソフト 
基本図形を変形させたり、面を生成し形状を作成していくことをモデリング

と呼びます。主にゲーム開発で用いられているポリゴン形状(3 角形又は 4 角形

の集合)を扱うモデリングであるポリゴンモデリングは、フリーソフトの「メタ

セコイア」や「六角大王」を使って容易に作成することが可能です。主要なハ

イエンドのソフトウェアとしては、LightWave3D や 3ds max，Softimage，
Maya があります。 
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3 3DCG の流れ 
まず、モデリングを行い、質感設定、カメラ、ライトの設定を行ってからレン

ダリングを行います。 
表１ 

モデリング 
Modeling 

形をつくる。 
ポリゴンモデリング(Polygon)、3 角形又は 4 角形の集合、ゲ

ーム開発 
NURBS モデリング(ナーブス)、工業デザインによる自由曲面 

質感設定 色や模様(テクスチャ)を付ける。 
モデルに陰影付け(シェーディングモデル) 
マッピング(Mapping) 
シェーダー(Shader) 
記述言語を用いてコンピュータに計算させることで模様 (テ
クスチャ)を生成 

レンダリング 
Rendering 

カメラでシーンを撮影し写真を撮るような作業 
Z バッファ、スキャンライン、レイトレーシング、ラジオシ

ティ(グローバルイルミネーション) 
アニメーション 
Animation 

キーフレームアニメーション 
モーションパスアニメーション 
インバースキネマティクス(逆運動学) 

映像制作におけ

る CG 技術 
コンポジット(既存映像と 3D の合成) 
Web3D 技術(VRML) 
ストリーミング技術 

 
● データについて 

・3 次元のモデルデータ→編集可能、変換して他の 3D ソフトへ持っていく

ことが可能 
・モデル、質感、カメラ、ライトを設定したシーンデータ→編集可能 
・レンダリング(映像を作成する)を行った後の画像データ→別途画像処理ソ

フトで編集・印刷 
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2 コンピュータグラフィックスとは 

 
● CG  Computer Graphics 

この定義は、広く 3 次元のグラフィックス(3DCG)の他に、2 次元のグラフィ

ックスを含んで指すこともありますが、コンピュータを用いて制作された画像

や映像のことを CG と呼んでいます。 
ただし、ただ単に入力装置(ディジタルカメラやスキャナ等)で入力した画像

データや、それを補正しただけのものは、ディジタル画像、またはディジタル

補正といった呼び方をしています。 
また、入力した画像をいくつか組み合わせて、作品を制作した場合、

Computer Graphics と言うよりは、Computer Arts と言ったり、フォトレタッ

チ、ディジタルコラージュと呼んだほうが良いでしょう。 
 この実習では 3DCG を取り扱う Alias 社の Maya を使います。 
 
● 3 次元空間 

 平面を表すためには、2 次元として X と Y の二つの方向を表す座標軸を使用

することで平面上の位置を定義することができます。X が横、Y が縦を表しま

す。 
 空間内、すなわち 3 次元の位置を定義するためには、X, Y, Z の 3 つの座標軸

で表現します。3 次元空間内の位置は「横」と「縦」に加えて「奥行き」を示

す 3 つの値で表現されます。 
3 次元座標は、Z 軸を「奥行き」として表しています。 
この実習では、次のような座標系を使用します。「右手系の座標」と呼んでいま

す。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

0 

z 

親  指  X 軸 
人差し指  Y 軸 
中  指  Z 軸 

y 

図１ 右手系の座標 
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3 3 次元グラフィックスの作成手順 

 
●モデリング   Modeling    物体をつくる 
●質感設定(マッピング) Texture Mapping  色を塗る 
●レンダリング  Rendering   カメラで画像を撮る 
●アニメーション  Animation   動きをつける 
 
(1)  モデリング 

形を作成することです。筆を持って絵を描くような作業ではなく、3 次元の

部品を使って立体物を構成していきます。この 3 次元の物体のことをオブジェ

クト(Object)と呼んでいます。 
モニタ(ディスプレイ)に表示されるオブジェクトを 3次元空間に配置します。

前後の関係である「奥行き」が表現されます。 
オブジェクトを構成する形式としては、3 角形や 4 角形の面の集まりで構成

されるポリゴン(polygon)形式と、少ない点でなめらかな曲線を表現する形式で

ある NURBS(ナーバス)があります。 
 

(2)  質感設定 
作成したオブジェクトに色を付けたり、表面に模様(テクスチャ)を設定した

りすることができます。質感は色(Color)、透明度、反射率や、でこぼこした質

感を出すバンプ(Bump)があります。テクスチャは 2 次元で表します。座標は、

3次元で X,Y,Zを使用しているので、これらと区別するために U,Vを使います。

数値は 0 から 1 の間の数値が使われます。 
これを UV マッピングと言い、形が変形すると、同じようにマップも変形す

る性質を持っています。 
また木目や大理石のような材質を自動計算するシェーダーもあります。 

 
(3)  レンダリング 

物体(オブジェクト)を 3 次元空間に配置した後は、次に光源(Light)を設定し

なければなりません。光源には、平行光源(遠光源、太陽光源、Distant Light 
Directional Light)、点光源(Point Light)、スポットライト(Spot Light)、環境

光(Ambient Light)があります。 
次に、カメラマンがスタジオで撮影するのと同じように、カメラを設定しバ

ックの風景を設定したり、光の当て方を調整したりして、実際の画像を計算す

る作業を行います。 
この撮影作業をレンダリングと言います。 

レンダリングにはいろいろな方法があります。それぞれ表現できるものの限

界があります。できあがる画像は変わってきます。 
レンダリング方法には、スキャンライン法やレイトレーシング法があります。 
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モデリングに凝ったり、ライトの数が増えたり、大きな画像をつくるとなる

とレンダリング計算時間は長くなります。 
 
(4)  アニメーション 

アニメーションはキーを設定することで、途中経過を補間して計算を行いま

す。 
アニメーションには、キーフレームアニメーションのほかに、曲線(パス、

path)に沿わせて設定したパスアニメーションや、関節の動きを再現するインバ

ースキネマティクス法があります。 
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4 Maya のインターフェイス 

Maya のメニューは、Animation、Modeling、Dynamic、Rendering にそれ

ぞれ対応しています。 
表２ 

モジュール 用途 ファンクションキー 
Animation(アニメーション) アニメーションの設定 F2 
Modeling(モデリング) 形状作成を行う F3 
Rendering(レンダリング) 静止画作成など F4 

 
● シーンの表示 

ビューは、バーチャルカメラを通して見た実際のビューです。デフォルトの

ビューには、パースビュー(Persp)になります。他に上面(Top)、前面(Front)、
側面(Side)に切り替えることができます。 
 
● カメラ操作 

シーンを見回すには、カメラを移動します。次の表のようになります。 
表３ 

押したままにするキー ドラッグするボタン 移動方向 
Alt(オルト) 左ボタン 視点回転(タンブル) 
Alt(オルト) 中ボタン 視点移動 (トラッキ

ング) 
Alt(オルト) 左ボタンと中ボタンを同

時に押しながらマウスは

左右に動かす。 

視点拡大縮小 

＊この操作方法は、HyperShade 内でもできます。 
① 視点回転 
 
 
 
 
② 視点移動 
 
 
 
 
 
③ 視点拡大縮小 
左ボタンと中ボタンを同時に押しながら  
マウスは左右に動かす。 
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実習 1 立体を配置する 

 

● 視点を変更する 

① カメラを回転させてみましょう。 
 
② ALT キーを押しながらマウス左ボタンを押しながらドラッグします。 

 
③ カメラを移動させます。 
 
④ ALT キーを押しながら真中ボタンを押しながらドラッグします。 

 
⑤ カメラをズームアップさせます。 

 
⑥ ALT キーを押しながらマウス左ボタンと真中ボタンを押しながら左右

にドラッグします。 
 

⑦ 拡 大 し す ぎ て わ か ら な く な っ た と き は 、 最 初 の 画 面 に 戻 る

View>Default Home を選択します。 
 

● 3D 空間にオブジェクトを配置する 

① 球体(Sphere)を配置します。 

② 球アイコン または、Create>NURBS Primitive>Sphere を選択しま

す。 
③ 配置される場所は原点になります。 
④ ワイヤーフレームで表示されます。キーボードを押すと以下のように変

化します。 
表４ 

表  示 キーボードの数字キー 
粗い(あらい) 1 
中くらい 2 
細かい(なめらか) 3 
ワイヤーフレーム 4 
シェーディング表示 5 
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● オブジェクトの移動・回転・拡大・縮小 

①Move ツール で球体を移動させることができます。 

②Scale ツール で球体を拡大・縮小させることができます。 

③Rotate ツール で球体を回転させることができます。 
 
④選択したオブジェクトを画面にフィットさせる(うまく収める)ためには、キ

ーボードで A キーを押します。画面が選択されていないと働きません。 
 
⑤選択されているオブジェクトは Delete キーで削除できます。間違って削除し

た場合は、Ctrl + Z キーで元に戻ります。 
 
⑥複数のオブジェクトを選択するためには、Shift キーを押しながら、クリッ

クしていきます。選択されたものは白で表示され、最後に選択したものは緑

色になります。 
 
⑦スペースバーを素早く押すことで、画面が 4 画面と Persp 画面に切り替わり

ます。オブジェクトの位置がわかり、各画面を見ながら移動しやすくなりま

す。 

をクリックすると４画面になります。 をクリックすると Persp 画面に

なります。 
 

● 物体の複製 

①複製したい物体を選択クリックします。 

②Move ツール を選択します。 
③メニューから Edit > Duplicate をします。物体が点線で表示されます。同じ

場所に重なっています。 
④Move ツールを使って、すぐに移動させます。 
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● 基本図形 

メニューの Create > NURBS Primitives から、基本図形が使えます。 
表５ 

基本図形 呼び方 主な形状 
Sphere スフィア 球体 
Cube キューブ 立方体 (選択したら上矢印キー↑を押す) 
Cylinder シリンダー 円筒(円柱) 
Cone コーン 円すい 
Plane プレーン 平面 
Torus トーラス ドーナツ 
物体を選択し、画面右側の INPUTS の下の行をクリックすると詳細設定ができ

ます。 
 

● 物体同士を見えない糸で結ぶ(親子関係)Parents 

① ある物体を選択します。(子を選択) 
② つぎに Shift キーを押しながら、別の物体を選択します。(親を選択) 
③ キーボードの P を押すと、最後に選択した物体が親になります。 
・解除するためには、子を選択して Shift + P と押します。 

をクリックすると親子関係が図示されています。真中ボタンを押しながら、

子を黒い何も無いところにドラッグすると解除できます。 
 
 

子 

子 

親  
 
 
 
 
 
 

図２ 
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● 物体の表面を変形させる 

メニューの Create > NURBS Primitives にある基本図形は、NURBS(ナーブ

ス)と呼ばれる自由曲面が使われています。青い田んぼのマークのコンポーネン

トモード に変更することで、オブジェクトが水色の線で表示されま

す。各頂点を選択し移動することで変形させることができます。 
 
 
● 地形をつくる 
① Create > NURBS Primitives> plane(平面)を選択します。 
② 切手くらいの小さな平面が出ます。 
③ 拡大ツールを使って大きくします。 
④ 画面右側にある INPUTS 下の makeNurbPlane…をクリックします。 

 
図 3 

⑤ PatchesU と PatchesV にそれぞれ 15 と入力し Enter キーを押します。平

面に格子が入ります。 

 
図 4 

⑥ 画面上の を に切り替えます。平面が水色になります。

紫色の四角が頂点になります。 
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⑦ Move ツールを選択します。マウスをドラッグして頂点を複数選択しま

す。頂点は黄色になります。そのまま緑色の矢印を上方向にドラッグする

と山や丘になります。キーボードの３番を押すと滑らかになります。 
 

 

編集が終わったら、必ず、

を押して、オブジェクトモードにし

ます。 

      図 5 

 11



実習 2 色を付ける 

① Window>Rendering Editors>HyperShade で HyperShade を呼び出します。 

 
図６ 

② HyperShade は色を準備する絵の具のパレットのようなものです。

HyperShade 内のメニューCreate>Materials>Blinn を選択します。 
 
③ HyperShade 右側の黒い何もないところに、てかりがついたグレーの球体の

モ デ ル が 現 れ ま す 。 blinn1 と い う 名 前 に な り ま す 。 く り か え し

Create>Materials>Blinn を選択し、作りたい色の数だけ出していきます。 
 
④ blinn1 アイコンをダブルクリックします。Attribute Editor が開きます。

Color の灰色の長方形をクリックするとカラーホイールが出ます。その中か

ら色を選択します。好きな色を決めたら「Accept」を押します。 
 
⑤ それぞれの blinn で色の設定を行います。 
 
⑥ HyperShade 内の色がいくつか決まったら、次のようにオブジェクトに色を

塗ります 
 
⑦ 方法 1  HyperShade 内の色が入った球体(blinn1 アイコン)の上にマウス

を置きます。真中ボタンを押したまま、塗りたいオブジェクトの表面まで

マウスを持ってきます。そこで真中ボタンを離します。オブジェクトに色

が入ります。 
 
⑧ 方法 2 オブジェクトをクリックして選択します。次に HyperShade の

blinn1 アイコンにマウスポインタを合わせます。このとき左クリックはし

ないでください。blinn1 アイコンの上で右クリックするとメニューが表示

されます。Assign Material to Selection を選択します。 
 

注意 標準である Lambert1 は色設定を変えないでください。 
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実習 3 ライト設定とレンダリング 

● レンダリングを実行する ライトを追加する 

① 選択されている View 画面がテストレンダリングされます。 ボタンを押

してください。レンダリングが開始されます。標準では 320×240pixels の

画像サイズになります。 
 
② 真っ黒のウインドウが表示されました。3D 空間では必ずライト(光源)の設

定が必要です。 
 
③ レンダリングウインドウを閉じます。 
 
④ メニューから Create > Lights > Point Light を選択します。原点にライト

が表示されます。 
 
⑤ Move Tool を使ってライトを移動させます。上方向に移動させてみましょう。

別の物体を選択して再び、ライトを選択するためには、四角を作るように

囲んであげます。クリックしてもライトは選択できません。 
 
⑥ ここでキーボードの数字キー7 を押してください。明暗が表示されます。 
 
⑦ ライトを再び、明るく照らすように移動してください。 
 

⑧ ボタンを押して、レンダリングを行います。 

 
⑨ ALT キーを押しながら、視点を変更してみてください。何回かレンダリン

グして、気に入ったカメラアングルを探してみましょう。 
 
 
⑩ カメラ枠を表示するには、View > Camera Setting > Resolution Gate を選

択します。 
 
● ライトの明るさの設定 

画面右側にあるライトのチャンネルボックスから Intensity の数字を変更す

ることで明るさが設定できます。０から１の間の数字で設定してみましょう。 
 
 

 13



● ライトの影の設定 
① ライトのチャンネルボックス下の項目 Use Depth map Shadow を on にし

ます。数字の１を入れて Enter キーを押すと on になります。０を入れて

Enter キーを押すと off になります。 
 
② ライトを選択し、Ctrl+A を押して Attribute Editor を呼び出します。 

▲Shadow をクリックして色を変更します。レンダリング ボタンを押して、

画像に影が出ているか確認します。 
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実習 4 2 次元画像出力と印刷 

 
レンダリングして作成された画像を保存します。これとは別に 3 次元データ

であるシーンデータ(Scene)がありますから、3 次元データは必ず保存しておき

ましょう。メニューFile > Save Scene で保存します。 
保存の種類として 2 次元データと 3 次元データがありますから注意してくだ

さい。後で 2 次元画像はいくつでも作成できます。 
 
● 印刷するためには 
 
① 大きな画像(2 次元データ)をつくる 

 
Window > Render Editors > Render Globals… 

▲Resolution → Presets → Full1024 に変更 → Close 又は×ボタン 

 
   図 7 

② でレンダリングを行います。大きな画像が現れます。 
 
③ 大きな画像の上にメニューがあり、File > Save image を選択し、名前を付

けて保存します。 
 

④ スタート→  photoshop で画像処理ソフトを起動します。 

 
⑤ メニューのファイル→開く 
 
⑥ ファイル→用紙設定→プロパティ 

 
印刷の向き 横に変更 
拡大縮小  100%を 50%に変更 
OK を押す。 
 

⑦ ファイル→プリント→OK 
しばらく待つと印刷されます。 
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● テクスチャ設定 

物体(オブジェクト)の表面には、色だけでなく、パラメータを変更して質感を

つくる機能があります。自動計算によって模様を生成するものをシェーダー

(Shader)と呼んでいます。 
● 目玉の作り方 
① 球を作成します。 

図 8 
② 回転ツールで向きを変更します。 

図 9 
③ HyperShade で新しく blinn を設定します。マウス真中ボタンをドラッグし

て、球に blinn を割り当てます。 

 図 10 

④ 設定した blinn をダブルクリックして、Attribute Editor を出します。Color
の項目右側にあるチェック模様のボタンをクリックします。 

図 11 
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⑤ Create Render Node ウインドウが開き、様々な質感が出ます。Ramp をク

リック選択します。 

図 12 
⑥ 緑を外します。 

図 13 
⑦ 青と赤をクリックしてカラー設定します、白○と黒●に変更して動かします。 
また、Type を V Ramp から「U Ramp」に設定変更します。 

図 14 
⑧ キーボードの数字キー6 を押すとできあがりです。適宜調整してください。 

図 15 

 
● テクスチャ模様の表示はキーボードの数字キー6 
HyperShade 内の blinn1 アイコンをダブルクリックします。Attribute Editor
が開きます。Color の右端にある白黒のチェックマークをクリックすると、様々

な質感模様を設定することが可能です。これを画面に表示させるためには、設

定後、キーボードの数字キー6 を押します。 
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● NURBS Primitive へ画像ファイルのマッピング 
 
① Create > NURBS Primitive > Plane で平面を呼び出します。 
 
② Window > Render Editor > HyperShade で新しく質感を設定します。 
 
③ HyperShade 内のメニューCreate>Materials>Lambert 又は Blinn を選択

します。 
 
④ 設定した球をダブルクリックし、Color の右端のチェック模様ボタンをクリ

ックします。 
 
⑤ File をクリックし、Image Name の項目の右にあるフォルダを選択します。 
 
⑥ 適当な画像ファイルを選択します。 
 
⑦ 設定した模様を平面に割り当てます。 
 
⑧ 画面内の物体を選択して、キーボードの 6 を押します。 
 
⑨ 画像が貼り付けられていることが確認できます。 
 
⑩ HyperShade 内の Place3Dtexture を選択して、回転や UV 値を変更するこ

とで模様を編集することができます。 
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実習 5 ポリゴンモデリング 

3 次元空間内では、3 点が決定すれば面を作ることが可能です。3 角形の面又

は 4 角形の面をポリゴンと呼んでいます。簡単なモデルを「押し出し(Extrude)」
機能を使って制作します。 
 
● テーブルをつくる 

方針 天板を作成し、分割した四隅から足を押し出します。 
① Create > Polygon Primitive > Cube > □を選択します。 

以下の数値を入力し、天板を作ります。 
表６ 

Width(幅)  60 (cm) 
Height(高さ)    8 (cm) 
Depth(奥行き) 40 (cm) 
Subdivision Width    3 (分割数) 
Subdivision Height    1 (分割数) 
Subdivision Depth    3 (分割数) 
 
 
Create ボタンを押します。 
 

② 直方体ができました。スペースバーを押して画面を切り替えます。4 画面を

表示します。各画面にマウスポインタを置き、A キーを押して画面をフィッ

トさせます。 
 
③ コンポーネントモードに変更します。オブジェクトが水色の線で表示され

ます。 

 
④ Move Tool を選択し、縦の列、横の列を選択して移動させます。 

 
図 16 
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⑤ Persp 画面にして、コンポーネントの Face をオンにします。板の四隅の

底部分を Shift キーを押しながら、選択クリックしていきます。 

 
      図 17 
⑥ 現在、Modeling モードであるか確認します。メニューEdit Polygons > 

Extrude Face を選択します。 
⑦ マニュピレータが現れます。下方向に押し出すために青い矢印の先(青い立

方体ではない)を引っ張ります。足が伸びます。 

 
      図 18 
⑧ Channel の INPUTS の polyExtrudeface1 の Local Translate に 45 と入力

します。 
 

⑨  真中のオブジェクトモードをクリックします。オブジェクトが

緑色の線で表示されます。 
 
⑩ メニューWindow > HyperShade を呼び出し、色を付けてみましょう。 
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● テーブルを複製する 
① テーブルを選択し、メニューEdit > Duplicate を選択します。 
② 複製した物体は重なっていますから、Move Tool で移動させます。 
 
● 床を配置する 
① Scale Tool を選択しておきます。 
② メニューCreate > NURBS Primitive> plane(平面)を選択します。 
③ Scale Tool を使って黄色の立方体部分をドラッグします。 
④ 繰り返しドラッグすると、拡大された平面がテーブルの中から現れます。 
⑤ Edit > Duplicate を行い、Rotate Tool で回転して壁にすることも可能です。 
 
● 押し出し(Extrude)の方法 

① コンポーネントモード にし、 をオンにします。 
② 押し出したい面を選択します。複数選択は Shift キーを押しながら選択しま

す。 
③ 現在 Modeling モードであるか確認します。メニューEdit Polygons > 

Extrude Face を選択します。 
④ 繰り返し押し出していきたい場合は、キーボードの G を押すと直前の命令

を繰り返すことができます。 
 
● ブーリアン演算 
物体を重ねておいて、片方を刃物としてもう片方を削ることができます。 
① 物体は Create > Polygon Primitive から呼び出します。 
② 1 つの物体(Polygon)を準備します。 
③ もう１つの物体(Polygon)を準備します。 
④ 物体同士を移動して重ねます。 
⑤ Shift キーを押しながら、残す方を最初に選択し、次に刃物になるほうを選

択します。 
⑥ Polygons > Booleans > Difference を選択すると削れます。 

   図 19 
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実習 6 キーフレームアニメーション 

● 直線的なアニメーション 

 図 20 タイムスライダ  

① 球を作成します。 
② Move Tool で画面の端に移動させます。 
③ ここでキーボードの S キーを押します。 
④ 1 フレーム目に登録されました。タイムスライダの 1 フレームに赤い線が縦

に入りました。1 フレーム目が開始位置になります。始点です。 
⑤ タイムスライダの 120 フレーム目をクリックします。 
⑥ 球の位置を変更します。好きな場所に移動させてください。 
⑦ ここでキーボードの S キーを押します。 
⑧ 120 フレーム目に登録されました。タイムスライダの 120 フレームに赤い

線が縦に入りました。120 フレーム目が終点位置になります。 
⑨ 再生ボタンを押します。アニメーションが再生されます。 

 図 21 再生ボタン 
 
注意 アニメーションを再生しながら、物体の編集は行わないようにしましょ

う。 
 
● キーフレームの設定方法のまとめ 

表７ 
・最初のフレームにする 
・1 フレーム目をクリック 

(グレーの縦棒) 
位置を決める→S キーを押す→登録(赤い線) 

・最後のフレームにする 
・120 フレーム目をクリック 

(グレーの縦棒) 
位置を決める→S キーを押す→登録(赤い線) 

 
● ホットキー 

表 8 
再生/停止 ALT+V 
巻き戻し Shift+ALT+V 
 
● キーフレームの削除 
キーの削除はタイムスライダ上の赤い線の上でマウス右ボタンを押すと、メニ
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ューが表示されます。この中から Delete を選択します。 
● オブジェクトに付いているキーフレームを削除 
Edit > Delete by Type > Channels を選択して設定したキーフレームを削除す

ることができます。 
 
● オブジェクトが回転するアニメーション 
① 円すいを配置します。 
② 1 フレーム目は何もしないで S キーを押して登録します。 
③ 最終フレームで Channel の Rotate X の箇所に、回転角度の数値を入れて

みましょう。1440 だと 120 フレームで４回転になります。 
④ S キーを押して登録します。 
⑤ アニメーションを再生します。物体の X 軸を中心に回転します。 
 
約１秒間に１回転の割合で回転します。 
 
● 物体同士の親子関係について 
① ある物体を選択します。 
② つぎに Shift キーを押しながら、別の物体を選択します。 
③ キーボードの P を押すと、最後に選択した物体が親になります。 
 
解除するためには、子を選択して Shift + P と押します。 
 
親子関係を付けて、回転アニメーションを行ってみましょう。 
 
注意  : マウスをドラッグして複数選択をしてアニメーション設定を行った場

合、物体の配置がくずれてしまいます。必ず、親を選択してから移動や

アニメーション設定を行います。 
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実習 7 モーションパスアニメーション 

● 2 次元の曲線上をオブジェクトがアニメーションする 
① 球体などのオブジェクトを作成します。 
② Create > EP Curve tool を選択します。平面にカーブを描きます。途中半分

まで描いたら、描画を終了するために Enter キーを押します。 カーブの

アイコンを選択すると良いです。 
③ Modeling モードで Edit Curve > Open/Close Curves を選択し、閉じたカ

ーブにします。 
④ まず、球体を選択します。(一度何もないところでクリックして球体を選択

すると良い) 
⑤ 次に Shift キーを押しながら、カーブを選択します。 
⑥ Animation モードに変更します。 
⑦ メニューAnimate > Motion Paths > Attach to Motion Path を選択します。 
 
● Animate > Motion Paths > Attach to Path > □の設定例 

表 9 
Time Range Start/End 
Start Time  1 
End Time 120 
Follow On 
Front Axes Z 
Bank On 

 
● モーションパスの設定を解除するためには 
Edit > Delete by Type > Motion Paths を選択して設定したモーションパスア

ニメーションを削除することができます。 
 
● オブジェクトのグループ化 
既にキーフレーム設定(タイムラインに赤い線が含まれている)がされているオ

ブジェクトはモーションパス設定を直接つけることはできません。 
 
しかし、オブジェクトをグループ化することでキーフレーム設定ができます。 
グループ化するためには、物体を選択し、メニューの Edit > Group を選択し

ます。 
グループの選択は、物体を選択し上矢印キー↑を押すと選択されます。 
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● アニメーション長さの設定変更について 

① パスアニメーションのカーブを見ると数字があります。 

 図 22 
② 数字をクリックします。2 つの数字（たとえば 1 と 120）が重なっている場

合もありますので、→キーまたは←キーを使って選択してください。 

③ 数字が選択されたら、メニューの Window から Attribute Editor を呼び出

します。ショートカットキーCtrl+A でも呼び出せます。 

 図 23 
Time の数字を変更することで長さを変更することが可能です。数字を入力し

たら Enter キーを押します。 
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実習 8 ウォークスルーアニメーション 

 
● カメラが、絶えずオブジェクトを見つめるアニメーション 
① 球体を作成します。 

② パスを作成します。描画を終了するためには Enter キーを押します。 

 
③ 球体を選択し、Shift キーを押しながら、パスを選択します。 
 
④ Animate > Motion Paths > Attach to Motion Path を行い、アニメーショ

ンの動作確認をします。 
 
⑤ 新しくカメラを作ります。Create > Cameras > Camera and Aim を選択し

ます。 
 
⑥ 原点にロケータ(注視点又はターゲット)を持ったカメラが作成されます。 
 
⑦ オブジェクトをクリックし、Shift キーを押しながら、ロケータをクリック

します。 
 
⑧ Animation モードで Animation > Constrain > Point を選択します。 
 
⑨ ロケータがオブジェクトにくっつきます。 
 
⑩ アニメーションの動作確認をします。 
 
⑪ Panels > Perspective > Camera1 を選択し、ALT キーを押しながら視点を

変更します。 
 
●まとめ  

表 10 
Create > Cameras > Camera and Aim 
オブジェクトをクリック→Shift キーを押しながらロケー

タをクリック 
Animation > Constrain > Point 
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実習 9 パイプの中を走るアニメーション 

 
● パスとカメラを設定する 

① パス(Curve)を作成します。 

 
② 新しくカメラを作ります。Create > Cameras > Camera を選択します。 
 
③ カメラが選択状態であることを確認し、Edit > Group を選択し、グループ

化します 
 
④ 画面右側のチャンネルボックスの名前が Group に変わっています。カメラ

をグループで選択しています。グループを選択する方法は、カメラを選択

し、上矢印キー↑を押すことでグループ選択することができます。 
 
⑤ Animation モードで Animate > Motion Paths > Attach to Motion Path を

実行します。 
 
⑥ アニメーションを再生します。 
 
⑦ もし逆に走った場合は Ctrl+Z で Undo します。 
 
⑧ アニメーションの設定、Animate > Motion Paths > Attach to Path > □を

呼び出します。 
 
⑨ Inverse Front を選択し、Attach し直します。 
 
⑩ 何も無いところをクリックして再び、Camera1 を選択して、Rotate Tool

で回転、向きを変更することも可能です。 
 
グループとしてカメラが設定され、group が親になり、モーションパスにくっ

つきます。子である Camera1 は、自由度を持つことになり要所要所でキーフ

レームアニメーションの設定を付けることが可能です。 
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● パイプをつくる 
① Create > NURBS Primitive > Circle を選択します。円を作成します。 
 
② カーブに対して、円を垂直に設定します。1 フレーム目で作業を行います。

(Move,Rotate,Scale tool を利用)。円はカーブを描いたときの最初の位置に

設定します。 
 
③ 円を選択した後、Shift キーを押しながら、カーブを選択します。 
 

④ 画面上の Extrude アイコンをクリックします。 
 
⑤ キーボードの 3 番と 5 番を押します。 
 
⑥ Panels > Perspective > Camera1 を選択し、アニメーションを再生します。 

 
図 24 
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実習 10 NURBS モデリング 

● 工業デザインで利用される自由曲面 
① オブジェクトの曲面を編集する。 

青い田んぼマークのコンポーネントモード で変形させます。 
 
● Revolve 回転 
ワイングラスや壺などの輪郭を作成し、回転させて立体を作ります。旋盤

(Lathe，レーシング)機能とも呼ばれています。 

① Front 画面で パス(Curve)を作成します。作成が終わるときに Enter キー

を押します。 
② 容器の輪郭を作成します。 
③ 画面上の Revolve(ワイングラスのような)のアイコンをクリックすると作成

されます。 
④ 最初に作成した断面を選択し、青い田んぼマークをクリックして編集する

と形状が変化します。 
 
● NURBS モデルの有機的なモデリング 
① Modeling モード 
② 球を作成します。拡大しないでそのままの大きさを使います。 
③ Edit NURBS > Rebuild Surface 
④ Edit NURBS > Sculpt Surface Tool > □ 
⑤ ツールを使って作業 
・Radius は 0.1 から 0.3 くらいに設定すると良いです。 
・Ctrl + Z で「元に戻る」 
・Opacity を最大 1 に設定すると力が強く働く。 
 
● NURBS モデルの 3D ペイントツール 
Rendering モード > Lighting/Shading > Paint Texture Tool > □ > Assign 
Texture 
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実習 11 自由課題 

● 静止画の制作 
① 画像サイズは 1027×768pixels とする。(Render Global で設定します。) 
② 印刷の向きは横、拡大縮小を 50%とする。 
 
● アニメーションの制作 
① 画像サイズは 320×240pixels。 
② 1 シーンの長さは 120 フレームまで。 
③ フレームレートは 24 フレーム/秒又は 30 フレーム/秒とする。 
 
● 炎のつけ方 
① Dynamics モードにします。 
② 物体を選択します。親子関係を付けている場合は子の部分を選択します。 
③ メニューEffects > Create Fire を選択します。 
④ アニメーションを再生します。なお親子関係になっている場合、親には設

定できません。子に設定します。 
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